HE2011: Der ganz normale Wahnsinn

9:37 h

Die Geräte werden eingeschaltet und Programme geladen. Beim C128 mit Wumpus 2.0 habe ich mich vertippt und muss resetten. Der Platz ist eng, da fällt mir mein Joystick vom Tisch. Splatter! Der glasklare Competition Pro zersplittert an der Aufschlagstelle. Kleine Plastikteile fliegen in alle Richtungen. Die Elektronik liegt frei. Autsch!

ehemals ein Competition Pro

10.03 h

Menschenmassen haben sich den Weg bis in die Halle 4 gebahnt. Heute sind deutlich mehr Besucher auf der Messe. Am Stand der CCL herrscht Gedrängel. Ansonsten ist es nicht übermäßig voll. Dafür laut! Dabei sollte das dieses Jahr anders sein. Pustekuchen. In den anderen Hallen ist noch mehr los. In Halle 6 (Modellbau) ist zeitweise kein Durchkommen. Dafür deutlich mehr Ruhe.

14:22 h

Die Programmierung des VDC in 40-Zeichen-Auflösung gerät zu einem Mysterium. Ich hatte schon mehrere Stunden der Codeanalyse darauf verschwendet herauszufinden, warum ich in meinem Programm immer dunkelgrau als Hintergrundfarbe habe. Dann entdeckte ich, dass mein Monitor (1901) in der VDC-40-Zeichen-Auflösung gar keine andere Farbe darstellen kann. Auch ein zweiter 1901 zeigte das selbe Ergebnis. Besser noch: wechselte man mit dem Color-Befehl (COLOR6,x) die Hintergrundfarbe, zeigten sich seltsame Effekte bei der Textfarbe. Man erhielt rote, blaue oder grüne Farbpaletten mit noch nie gesehenen Farbtönen. Die 16 Originalfarben waren nur bei der Hintergrundfarbe Schwarz sichtbar.

Seltsamer VDC
Schwarz (COLOR6,1) zeigt die original Farben; COLO6,9 eine grüne Palette

Wie sich später herausstellte, zeigt ein andere RGB-Monitor (von Profex) jeweils das, was angezeigt werden sollte: ein andersfarbiger Hintergrund bei korrekter Farbpalette. Warum der 1901 beim VDC mit 40-Zeichen pro Zeile derart „spinnt“ (im 80-Zeichen-Modus arbeitet er ja einwandfrei) muss vorerst ein ungelöstes Rätsel bleiben.

16:55 h

Der Lärm in Halle 4 schwillt auf einen unerträglichen Pegel an. Die Radaubuden am Hallenende haben das Fernsehen zu Gast und drehen auf was geht. Hier geht jedoch nichts mehr, jedenfalls keine Unterhaltung. Später wird es wieder etwas leiser, trotzdem bleibt es unangenehm und immer wieder meint jemand seine Boxen größer aufdrehen zu müssen als der Trottel von nebenan.

17:50 h

Die Messe geht dem Ende entgegen. Inzwischen wurde auch ein Commodore 1084 S bezüglich des VDC-40-Zeichen-Phänomens getestet. Auch dieser Monitor zeigt, wie der 1901, die seltsamen Farbpaletten anstatt unterschiedlich farbiger Hintergründe. Irgendwie finde ich das nicht wirklich beruhigend.

Dieser Beitrag wurde unter Events veröffentlicht. Setze ein Lesezeichen auf den Permalink.

9 Kommentare zu HE2011: Der ganz normale Wahnsinn

  1. tokra sagt:

    Um die Farben beim 40-Zeichen-VDC-Mode sauber zu bekommen musst Du die Register 34 und 35 (Display Enable Begin und End) entsprechend anpasssen. Vermutlich musst Du die Werte die normalerweise drinstehen einfach halbieren.

    Den Effekt mit den komischen Farben am 1901 kannst Du dann vermeiden. Meine Theorie ist, dass der Rasterstrahlrücklauf ohne korrekte Einstellung der Register an der falschen Stelle losgeht und es dadurch zu Farbverläufen kommt. Den selben Effekt kannst Du am 1901 auch beobachten wenn Du den Hintergrund auf Weiß stellt (Color 6,2) und das Bild mit dem Regler nach rechts schiebst.

  2. wte sagt:

    Danke für den Hinweis. Das Register 34 hatte ich schon selber manipuliert. Der Wert ist relativ egal, viele 40-Zeichen-Umstellvarianten ignorieren es und behalten den Standardwert bei, was auch sinnvoll erscheint, denn technisch werden ja genausoviele Bildpunkte dargestellt wie zuvor. Die horizontale Auflösung ist zwar halbiert, aber die Punkte sind doppeltbreit. Dem Rasterstrahl sollte der Unterschied also auch nichts ausmachen (und genauso verhält es sich auch). Das Register 35 wird in keiner mir bekannten Variante angefasst. Ich werde aber bei Gelegenheit beide Register nochmal richtig quälen.

  3. tokra sagt:

    Register 34 und 35 rechnen in Characters nicht Punkten!
    Laut C128 Programmer’s Reference Guide:

    R34, R35 DISPLAY ENABLE BEGIN, END
    During the horizontal and vertical synchronization pulses, the R, G, B and I signals must
    be blanked (brought to a low level) to prevent the display of the scanning beam during
    retrace times. Two registers allow the user to adjust the beginning (R34) and end (R35)
    of the horizontal blanking interval.
    Register R34 is programmed with the number of characters from the first dis-
    played character of a row to the first blanked character in that row. Register R35 is
    programmed with the number of characters from the first displayed character of a row to
    the last blanked character in that row. Blanking occurs on all scan lines of a frame.

    Wobei ich die Beschreibung nicht ganz korrekt finde. Register 34 ist „Display Enable Begin“, also ab welchem Zeichen das Bild angezeigt wird (Wert 125). Register 35 ist Display Enable End, also ab welchem Zeichen das Bild abgeschaltet wird, damit der Rasterstrahlrücklauf nicht stört (Wert 100). Bei 127 Zeichen (Wert 126 in Register 0) ist das Display also am „rechten“ Rand deaktiviert (in dieser Zeit läuft der Rasterstrahl schon zurück).

    Unter:
    http://www.forum64.de/…/board95-c128/41693-80×50-zeichen-f-r-den-c-128/

    hatten Dirk und ich den 40 Zeichen-Mode schon mal an Rande diskutiert. Wenn man Register 34 und 35 nicht anpasst an den neuen Wert in Register 0 verhindert man also effektiv das Ausschalten des Rasterstrahls im horizontalen Rücklauf, das kann dann wohl zu dem von dir beschriebenen „dunkelgrauen“ (statt schwarzem) Hintergrund führen. Beim normalen C128-Mode ist der Bereich von 100-125 „display disabled“. Also muss bei halbiertem Wert in Register 0 ein ähnlich großer Bereich reserviert werden. Ich bin gut gefahren mit R0: 63, R34: 0, R35: 55. Das ist zwar ein etwas schmalerer Bereich, lief aber soweit bei mir. Anpassen kann man das noch mit Register 2 (Horizontal Sync Position). Der VDC ist da schon ziemlich flexibel.

  4. wte sagt:

    Wie schon erwähnt, wird in keiner mir bekannten 40-Zeichen-Umstellung das Register 35 angerührt. Und das ist offenbar ein großer Fehler. Bei schwarzem Hintergrund fällt das allerdings nicht auf.

    Die Idee, die Werte einfach zu halbieren (für beide Register) ist übrigens nicht ganz so schlecht. Ich habe den 40-Zeichen-Mode mit Herumprobieren für folgende Werte optimiert: R34: 62, R35: 55. Das sind jeweils die Mittleren Positionen eines zulässigen Wertebereichs.

    Mit weiterem Experimentieren habe ich noch einen zweiten, etwas breiteren Wertebereich ermittelt, der sich mit Deinen Werten fast deckt. Optimal sind da R34: 3, R35: 56. Wirklich interessant, dass das Register R34 sowohl mit 3 als auch 62 eine stabile Darstellung erlaubt.

    Ich habe jetzt allerdings ein anderes Problem. Dem ersten Zeichen in jeder Zeile fehlt die erste Pixelspalte. Smooth Scroll horizontal (R25) ergibt jedoch leider einen schwarzen Innenraum (Zeichen und Hintergrundfarbe „verschwinden“), wenn ich den Wert des Register um eins erhöhe. Ich habe verschiedenes probiert, aber jetzt gehen mir die Ideen aus.

  5. tokra sagt:

    Also das mit der fehlenden Pixelspalte kann ich nicht bestätigen. Ich hab das eben im DIN-Modus mit Shift+L sowie Shift+P geprüft und sehe sowohl den linken als auch den rechten Rand. Ein Artefakt hab ich aber trotzdem: Im Revers-Mode (ESC+R) habe ich bei anderen Farbkombinationen immer eine Pixelspalte ganz rechts türkis. Diese bekomme ich mit Register 25 zwar breiter, aber nie ganz weg.

    Kannnst Du mir mal deine Einstellungen oder gleich das Programm zusenden? Meine EMail solltest Du ja haben. Dann teste ich das mal quer.

  6. tokra sagt:

    Ergänzug: Hab den türkisen Rand gerade wegbekommen, lag nur an einem WINDOW 0,0,39,24 Befehl. Ohne diesen funktioniert der Editor natürlich nicht so schön. Tatsächlich sehe ich aber vom 41. Zeichen die erste Pixelzeile, habe netto also 40×8+1=321 Pixel sichtbar.

  7. wte sagt:

    Und da irrt sich der Experte! Es sind eigentlich immer noch 640 Pixel. Nim mal eine andere Farbe als Hintergrund (z.B. Grau statt Schwarz), dann erkennst Du, dass sie erste Pixelspalte fehlt. Die erste Linie ganz links hat immer nur die halbe Breite (eine logische Pixelspalte hat ja jetzt zwei physikalische Pixelspalten). Hell auf Schwarz wird das „überleuchtet“ und man erkennt es nicht. Schwarz auf Hell verschwindet die Linie fast ganz.

    Du hast also 15+39*16+1=640 Pixel auf dem Bildschirm. Oder anders, in logischen Pixeln, ausgedrückt: 1/2+319+1/2=320. Von der ersten (logischen) Spalte des ersten Zeichens fehlt die Hälfte und von der ersten (logischen) Spalte des 41. Zeichens sieht man die erste Hälfte als „Artefakt“. Sieht nach einem Bug aus.

  8. tokra sagt:

    Ah! Ok, jetzt weiß ich was Du meintest. So gut sind meine Augen auch nicht mehr 😉

    Stimmt es sind 640 Pixel, wobei rechts ein Pixelspalte zuviel und links eine zuwenig sind. Beim 40 Zeichen-Mode macht das dann natürlich nur eine halbe Strichbreite aus, deswegen bleiben Zeichen wie Shift+L erkennbar, aber dem linken Strich fehlt die richtige „Dicke“. Hab jetzt auch kein Register gefunden mit dem das korrigierbar wäre. Wohl einer der verbleibenden VDC-Bugs.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Time limit is exhausted. Please reload CAPTCHA.